冷轩信 冷轩信

amh 4.5 安装脚本备份

in 冷轩纪 文章转载请注明来源!

备份下amh 4.5 也就是vps看客二次开发的amh.4.2版本

我这里的是针对ubuntu 14.04 版本的安装脚本,修改了libiconv的源码,其他系统不保证可以正常。
注意不能安装AMProxy模块,会导致nginx启动脚本消失,反正尽量不要安装需要编译的模块就对了。

wget http://7xr36x.dl1.z0.glb.clouddn.com/amh/files/4.5/amh.sh && chmod 775 amh.sh && ./amh.sh 2>&1 | tee amh.log

功能增加:增加php5.4 php5.5 php5.6
php7.6,支持从php5.3~php7.0自由热切换。每个虚拟主机可以进行切换,不需要整个环境的切换。

开发日志:
1.新增php7.0,实现php 5.3 5.4 5.5 5.6 7.0所有版本虚拟主机级的一键切换。
2.mysql数据目录迁移到/home/mysqldata,方便统一管理和多分区用户重装系统能保留home分区下的重要数据。
3.部分bug修正 以下为旧记录:
1.nginx升级到1.9.6,配合新版nginx,openssl编译1.0.2d(nginx专用)
2.支持http/2(目前测试中,站点conf文件需要手动加入配置,参考nginx.org)
3.支持stream反代
4.支持nginx反代和cache_purge(测试功能,配置文件需手动)
5.修复pid路径错误在服务器重启后不能启动php的错误
6.其他一些bug修复

启用http/2的方法: 模块下载个bbshijiessl,然后用这个模块配置好ssl证书
手工找到/usr/local/nginx/conf/vhost/域名.conf 里面最下面把listen 443; 改成 listen
443 ssl http2; 面板里重启下网站即可


最后附上vps看客的修改amh 4.5 安装

wget http://soft.vpskk.com/amh/files/4.5/amh.sh && chmod 775 amh.sh && ./amh.sh 2>&1 | tee amh.log
文章二维码

扫描二维码,在手机上阅读!

发表新评论
已有 4 条评论
  1. giant888
    giant888
    回复

    ESET 报告说你的网站是恶意攻击站点。不知道怎么回事。

    1. 冷轩信
      冷轩信本文作者
      回复

      @giant888 我也被火狐说是恶意攻击网站,百度安全联盟弄的,以前申诉过,后来又这样了,不管了,反正我不用火狐

  2. 搞网赚
    搞网赚
    回复

    抱歉,我的网站 网络赚钱 make-money.org已经改名为搞网赚: www.gaowz.com,方便的话,更更新下链接,谢谢!

  3. 上海项目管理软件

    好文章 值得推荐


© 2017 由 Typecho 强力驱动.Theme by Yodu
前篇 后篇
雷姆
拉姆
音乐加载中...
0:00